Warhammer 40,000: Inquisitor - Martyr Wont Launch


Just picked this up on steam last night (May 25th 2023) with the sale, and it wont run. spent 7 hours running through posts from 2018 at the earliest trying to fix it and no luck. figured i'd sleep on it, maybe it would magically work the next day, windows is weird that way sometimes.

Processor: AMD Ryzen 9 5900X (12-Core) 4.8 GHz Turbo
Motherboard: ASUS PRIME X570-P / MSI X570-A Pro (AMD X570)
System Memory: 64GB DDR4 3200MHz
Graphics Card(s): 1x GeForce RTX 3060 Ti 8GB (VR Ready)
Operating System: Microsoft Windows 10 Professional (64-Bit)

things ive tried (not in order, listing from memory of last night):

(everything from every post since 2018 about this issue)

checking the cache, twice -after each reinstall

reinstalling, multiple times

deleting all remaining files after an uninstall (which is 1 empty folder, because the game never launches, theres no remnants)

installing everything in that install folder that windows allows

installing a feature pack (WMVcore)

grabbing a working d3dx11_43 from a trusted friend

grabbing a working d3dcompiler_46 from a trusted friend

tried the compiler fix 47 (then later found a post saying not to do that even if it works for others, so i stopped doing such)

there is no reg file to delete, the game hasnt started launching

there is no logs, the game hasnt started launching

compatibly mode does nothing for any version of windows

running as an admin allows me to see the error message, but the game doesnt run

restarting steam multiple times

my os and gpu are up to date

custom launch options

allowing on my av

turning off my av

it doesnt show up in task manager at all

and restarting computer after each attempted 'fix'

this is my current error: 

i click play, i confirm i want the game to run through the admin panel, and i get this error

edit: additionally ive tried resolution fixes and audio fixes 

This post was edited 131 days ago by MrCandy22
Store Page
Warhammer 40,000: Inquisitor - Martyr Wont Launch
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
125 days ago
Hi, sorry I missed that. Have you tried all the possible fixes from the article from my previous comment? 
125 days ago

i tried that, thanks, i tried checking my cache at least a dozen times. - its the first thing i listed.

this does not fix the issue

This comment was edited 125 days ago by MrCandy22
127 days ago


some research suggests this error message is most likely due to file corruption. That might be external app files, or files on your PC. For starters, could you try verifying the integrity of your game files on steam? (if you haven't done so already during your very thorough process.) To do so 

  1. right-click on the game from the Library and select Properties from the menu.
  2. Select the Local files tab and click Verify integrity of game files...

if this doesn't bring you any results, there's an article I would like to refer you to, maybe going through those fixes will bring the desired result. 


Please get back to me about if any of this helped or not. Cheers!

This comment was edited 125 days ago by oeregharcos