Warhammer 40,000: Inquisitor - Martyr Definitive Edition no DLC


After purchase the game is installed but DLC seems not, Steam says that will be installed after game launch but after launching -Prophecy and -Martyr still doesn't download/activate them.

Maybe there is some action on steam or on game that I need to do, but there are no clues.

Store Page
Warhammer 40,000: Inquisitor - Martyr Definitive Edition no DLC
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
155 days ago

The game is OK now, ty

155 days ago
Hey! We did publish a fix for this issue a couple days ago. Can you still not access your DLCs? 
156 days ago
After some testing, seems not working if you launch using "prophecy", must launch "martyr" first, then it appears in both.

Seems there are problems using the 2 launchers, doing it some stored loot disappear from the storage sometimes disappear.

I feel your game one of the more adherent on the 40K mood in ambientation and gameplay, so I hope you can iron out this small winkless :)

Emperor Protects

157 days ago

Hi guys! We fixed this issue in the past couple of days, could you please confirm it's working for you now? :)

159 days ago
Same issue. I launched both on steam, redowloaded etc. Followed all of steams suggested steps. I have access to the DLC characters, but its askng me to purchase the DLC missions with fate. is that normal?

160 days ago

there will be no answer.. right?

This comment was edited 160 days ago by Evan Game
161 days ago

i have the same problem