Void Crusade Freeze Bug


Steam version. Roughly 9:30 CST, I hit the teleporter at the end of a Nurgle boss level in Void Crusade & began looting the surrounding chests. I paused to bring up inventory, switched armor to a red set, then found a better one in the same menu session and switched to it. When I unpaused, the game stopped responding & the Heavy Weapon Crusader froze still, mid-step. I paused again and moved to inventory and tried switching my armor back, but it just changed the appearance without restoring control. Besides pausing menu options, whether using controller or mouse, no effect in-game would happen.

This post was edited 125 days ago by SpaceOdin
Store Page
Void Crusade Freeze Bug
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
114 days ago
Please check your Psyker (his inventory). Some things are there since you lost the loot in the mentioned mission.
125 days ago
You're right! There's a blank space between the e and the O. "Space Odin" should be it. Thank you!
127 days ago

I cannot find you in our system. Did you add the correct name?

We are looking for the name displayed in the left upper corner while you are playing.

This comment was edited 127 days ago by Marcopolocs
127 days ago
I did lose all my loot :(

My Steam account name is captainmunky. Thank you!

128 days ago

Thanks for the detailed report. We will try to reproduce the bug. As a result did you lose the loot you tried to collect? If yes, please let me know your account name. Thanks!