Something went wrong while connecting to the Gamesparks Servers Error - how to solve?

12

Hello,  I've been playing Martyr for about 10 days and had no issues. Today, couldn't play at all due to that Gamesparks Servers Error. Found nothing about the state of the servers, and here on the forums the few topics about that issue are very old. Besides, even on those, no actual explanation for the problem was given.  Restarting my PC and verifying the game files on Steam made no difference. 

So, is the problem on my side? Is there anything I can do, or is it server based and all that can be done is wait?

Thank you.

Store Page
Share
12 comments
110 days ago
MessfelrioN

Are you still unable to login? 


Then please try the followings:

- First and foremost add the game to the exceptions of both your Firewall and Antivirus. Any of them can block the connection sometimes.

- Check if you Windows is properly updated

- Delete the registry files here: Press Win+R, type into the appearing window 'regedit' and after finding the NeocoreGames folder, delete the whole Warhammer Martyr subfolder from there

- Lastly, create a new Windows user with admin rights and check if you then can launch the game without any issue.


This comment was edited 110 days ago by Marcopolocs
113 days ago
Marcopolocs

I have a connection problem. Writes that the servers are unavailable.

210 days ago
+3

Hey there,

we are sorry for the unpleasant experience. Steam ran a maintenance on their end and our backend server could not recognize the game until the maintenance did not end. It is over now though, logging into the game is once again possible.



Let us know if you still experience any connection-related issue.

210 days ago
+1
SkinnyHippo
That's right, managed to connect again, the issue seems resolved.
210 days ago
+1
It seems like the issue has corrected itself. Try logging in now.
210 days ago
I'm experiencing the same issue - working fine yesterday / cannot log in now (first time I've tried today).
210 days ago
+1
I cannot seem to connect either. It was working fine yesterday. Getting the same error.
210 days ago
+3

Made an account just to say I'm getting the same error. Maybe some ports changed or something? Sad part is I've only ever played solo anyway....

210 days ago
+3

Did the same as the OP,  rebooted and verified files. No luck

210 days ago
+4
I get the same error. Unfortunately the only thing I know to do is wait.
210 days ago
+4
Same problem here. Following.
210 days ago
+4
I get the same error - "Something went wrong while connecting to GameSparks Servers. Please try again later."