Bought the game a few weeks ago, I can’t connect to multiplayer, and my dream shards no longer show to make purchases.  This was just released on PS4, it’s been this way for a week.  Is this still supported?

Store Page
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
2 years 16 days ago
This comment was deleted 2 years 15 days ago by Marcopolocs
3 years 81 days ago
Seems to be working after the updated.  I couldn’t find anyone online,  but that could take a bit for people to come back to this game.
3 years 82 days ago

We would like to inform you that the followings issues have been fixed on PS4:

  • Multiplayer connection
  • Dream Shards
  • Achievement unlock issues

We had a hard time with this bug but with the help of Sony's support we could resolve the problem. We would like to ask everyone who experienced any of the bugs above to check on their account and let us know if they still experience any issue.

Our apologize for the long waiting time.

3 years 95 days ago
Another updatE, yet the only real problem persists.  Is there still no progress on fixing the multiplayer connection issue, or the disappearing shards?  Last I saw the problem was unable to be reproduced by the devs, I have no problem reproducing it myself, %100 of the time.  Any update on progress would be appreciated. 
3 years 116 days ago
So some update that really didn't do much a tutorial video.   Still shards only shows "???" no matter how many times you reboot the system.  Previously it was random that it would work.   It's not even useful to play the game.   Received some email from a person here but, don't think it will do much.  We'll have to wait for them to fix since SONY / PS4 currently won't give you any refund.    Not going to purchase any games from this company when they release games that really don't work.  Without Shards found in the game or purchased you can't upgrade and really play the game correctly.  FIx the damn game or Refund us please.. 
3 years 116 days ago
Again.... had update yesterday (around 310 Mb) and nothing has changed.....
3 years 117 days ago
Can't play the game at all for hours.
3 years 118 days ago
Identical problems.  How to get a refund for the game and shards purchased.   Is now the questions.. 
3 years 118 days ago
This is the same here .. Can't play the game the way it was intended.  Can't buy anything without shards.  Only get ??? - want a refund for the game since it isn't working.    Now how todo that is the question. 
3 years 122 days ago

Same thing going on for me. Bought 500 shards first day, and was able to purchase 1 special offer item. Since then, nothing. Cannot connect to server for mp, shard inventory shows ??? and unable to purchase any other special offer items.

Is this going to get fixed? If not I would like my 9.99 refunded please.

Figured I would help support the game buying the shards, but in hindsight doesnt seem like that was a good idea.

3 years 123 days ago
Op here, issue still ongoing.  I’m not seeing any communication, is there any attempt at addressing this issue?  Do the devs own a PlayStation 4 that they can test this on?  
3 years 127 days ago
Hi Worldtour1966.

I also have the same issues since day 1 I bought the game...
As for point 5: Yesterday I had to restart 3 times before it worked... Only had this case once though. Usually 1 restart is enough...

3 years 128 days ago
Hello, I like to report some problems with deathtrap i am facing with, they are:

1. can't connect to multiplayer for almost 2 weeks now

2. can't connect to leaderboards

on 1 and 2 there's a pop-up box saying infinitely connecting....

3. my trophies don't pop-up anymore after they did the first couple of days, and i'm absolutely sure i fulfilled the requirements. for instance reach 50 and 100 stars on the campaign map. I have over 110 stars on my sorceress and no trophies. there are other trophies as well, but these are the most basic2.

4. When i play endless mode with my sorceress on Darkmoor (the first map) the game closes with a blue error screen between levl 25-30. This happened to me on 3 different occasions.

The psn error code tells me to ensure i have the latest game version and psn software. Both are the case. 

5. Every now and then when you load a map i'm unable to upgrade my traps after bying the trap. Annoying but when i press restart the map it's working again. Nevertheless this should not happen. I always play online with no internet issues in any other game.  My PSN name is Worldtour1966.

When i read on internet that xbox had similar problems 3 years ago, it really makes me wonder why the staff at neocoregames didn't test this game properly especially on these issues.

I hope this will be fixed in the shortest time possible and with the highest emergency.


3 years 131 days ago
Hi @Marcopolocs.

My internet connection is always working and I always play my games online... I never deactivate this.
I checked everything and confirm to you that this is still the case. Also my PSN updates are done as soon as they are released the first time I connect on my console.

3 years 131 days ago
Most certainly on-line.  
3 years 132 days ago
Lol skinny hey I have u added on psn this game is shit like really the staff say there fixing shit yet so far nothing is fixed they put a patch out and the problem is still going it's like they are trying to make u want to request they be shut down shit ass staff that can't fix stuff it's sad I reported this right when it happened and they haven't done anything to fix it
3 years 132 days ago
Could you please tell me if you are playing with Deathtrap in an offline or online mode? As we found if you have some Dream Shards and your device has no connection to the internet then the Shards will not be displayed properly.

Please let us know if this is the reason or not. Thank you for your feedback in advance!

3 years 132 days ago
I have the same issue with the dream shards. It just shows as ??? for the amount. Not even fixed after the new patch.
3 years 134 days ago
Hi all.

Bought the game this weekend and have the same issue on PS4.
Bought some shards and could use them once. After logging out and back into the game a few hours later I just see 3 question marks instead.