Priority assignment post loot screen bug (not getting glory)



After doing a priority assignment some times the loot screen bugs and disappears, it is there for less than a second. I get items but not the glory. I have not found anything that links together when it bugs and when it does not. 

I have just done a priority assignment and it bugged - i do have more then the weekly 800 needed, can that be the problem?

I found a person on the steam forum who has the same problem:

Kind regards

Edit: I found one more with the problem. Maybe the accounts has something in common:

Edit 2: I did 2 priority assignments to see if the loot screen would bug if i was under the glory limit. 2 full runs and it bugged out both times and i got no glory i do get the items it would seem. Hope you can fix this as it seems other people are having the problem too.

edit 3: I tried different difficulties and it still bugged. I tried with the "skip loot screen" option on. I got the tiny loot button in the middle of the screen 1/3 down and the message that i could not chose a new mission because i had loot waiting. It disappeared after 1 sec  and i was awarded no glory

edit 4: I tried to run a priority assignments in full screen on a single monitor instead of the two i normally run. The loot screen still bugged and i got no glory.

edit 5: I tried to not use the astropath after starting the priority assignments but go through the map. The loot screen still glitched

Edit 6: I have tried to do nothing else than start a priority assignment never skipping text or other animations . It still glitched.

This post was edited 3 years 34 days ago by FrostV
Store Page
Priority assignment post loot screen bug (not getting glory)
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
2 years 360 days ago
It would seem that after the season ended the problem is solved. I had 30+ bugged rewards and like 2 that went on normally during the season. After the i have yet to get a single bugged reward.
3 years 32 days ago
Thank you.
3 years 32 days ago
This has been a pending issue for quite some time as I (and one tester colleague) tested the assignments a couple of times but there were no results. I will get back on the issue in the coming days once more, hopefully more results will come out of it than last time.

Thanks for the heads-up!

3 years 33 days ago

@MARCOPOLOCS‍ hey i know you might have better things to do but i would just like make sure you know of this bug before the post is pushed to the back of this forum.