Mission problem

4

I can't start mission Uther Secret in Inquisitor Martyr. Someone know how to fix this?

Store Page
Share
4 comments
Mission problem
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
276 days ago

Make sure you meet the required mission level and have completed any prerequisite missions needed to unlock it.

323 days ago
Gr3mlin
How exactly is it that you can't start the mission. You click on a character with a '!' mark, and nothing happens? 

Or are you trying to start the mission in the upper right corner of your screen? 

Have you tried starting it from the mission deployment screen? If not, please try starting it that way. You can access the screen from the taskbar at the bottom of your screen, whenever you are on the bridge of the ship, or in the Starmap. Let me know if any of this solved the issue. In the meanwhile I'm forwarding your case for some deeper testing, since I couldn't find anything wrong yet with your account. Thanks for the patience!

323 days ago
oeregharcos
My account name is Dekturion. My character is 59 lvl crusader Tyberius. I play on PC by Steam.

Thanks if you can help.

324 days ago
Hey, did you encounter this issue on your level 7 Psyker? If so, I've fixed the issue. If not, could you please provide me with some additional info?

What is your in-game account name?
What platform are you playing on? (PC/PS/Xbox)

Cheers!