Invisible mouse on start Keyboard unresponsive


Ok so it's been a year (at least)  since I played deathtrap. but i came back to it and updated it to play.  It SEEMS now it requires an x-box controller to play.  The main menu is labeled with x-box buttons and the mouse is invisible.  I don't have any controllers plugged in, but I tried to plug in my ps4 controller that I use all the time with rocket league and it won't accept any input.  The mouse I know is invisible because I can move the mouse and click randomly and it went to a tutorial screen.  On this screen, the mouse is visible, yet still xbox buttons all over the place.  No matter where I click or what keyboard or controller buttons I press, it won't progress any further.

A little help pls?  I used to only play it with kb mouse and I've never owned an xbox controller.  Not sure what or how anything changed.

Store Page
Invisible mouse on start Keyboard unresponsive
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
5 years 243 days ago

I fixed it.

I use a windows service called "SCP DSx Service" for psx controllers.  I had to Stop the service for the mouse to come back and the game to stop prioritizing controller controls over mouse and keyboard controls.