Helmet not unlocking after finishing Mind Plague DLC (PC)

5

I completed the Mind Plague priority assignment DLC, but the helmet is still locked. Tried restarting the game, but no change.

Store Page
Share
5 comments
Helmet not unlocking after finishing Mind Plague DLC (PC)
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
166 days ago
Slym1764
Could you please let me know what your in-game account name is? 
168 days ago
oeregharcos

I run a dozen missions and relaunch the game 3 or 4 times since yesterday. 

And I bought another mask to the vendor who appeared fine immediately.

Still nothing for the DLC mask. 


169 days ago
Slym1764
It can happen on occasion that the visual interface doesn't synchronize with our backend immediately. It should after a couple save/load loops, so I advise you try and do the same, just run a couple missions and see if it gets unlocked in the process
170 days ago
oeregharcos
The same thing just happened to me. 

I was searching if it was a known issue and I saw this discussion. 



187 days ago
Hey! Please try running a couple missions and restarting the game a couple times :) If none of these unlock the helmet let me know! Cheers!