Can't play with friends


When joining a game it appears the next message: "connecting to server"; "connecting to resolve server 1...2....until 9 or 10"  and, finally, a message saying: "unable to connect to resolve server". It was the same for two friends of mine. Is there any solution for this problem? Our version of the game is The Final Cut.

Store Page
Can't play with friends
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 358 days ago
Issue resolved for me, server side problems it seems.
1 year 358 days ago


I would like to provide some info,  maybe it can help solving this.

I have found this info on the net about the ports : 


I have opened the ports :

I read that the game tries to use P2P firstly , then if it doesn't work , try to resolve the connection with the help of the servers.

I can not turn on P2P in my router , the option is missing :

My internet provider is DIGI Hungary, and I am using win10. Trying to play via steam with a friend.

I have make exceptions in the firewall also , and tried it off too.

Hope you can help me, us .

Best Regards,


This comment was edited 1 year 358 days ago by sotte
1 year 358 days ago
Ports open, firewall off, same issue.
1 year 358 days ago

Me too. The game failed to connect with my friend.:((

1 year 359 days ago

me too , we forwarded some of the ports that were mentioned on forums , didn't work.

Also tried firewall off

1 year 359 days ago
I have the same issue