blueprints for contsruct weapons

6

i could buy the blueprint for the cataphron greataxe, memorize it and craft it, but not equip it. i havent read the games update history, but i guess it´s a rudiment from before the class overhaul. well this rudiment irritated me as a new player as i thought first i was too stupid to equip stuff. my knowledge about the game is still not big but i hope i could explain my problem and i hope it´s a bug! thx for the great game.

Store Page
Share
6 comments
blueprints for contsruct weapons
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
2 years 48 days ago
Nostromo21

I compensated all the credits and Fate points you had. Probably on your non-Seasonal account? I can't remember exactly where but I did. This happened on your Seasonal account?

2 years 50 days ago
+2
Nostromo21
I have never seen a post deleted by Neocore - not even very critical ones (I posted a couple myself). I don't recall even seeing a mod edit, come to think of it. I had one or two posts disappear due to some website or browser glitch, but that's it.


If you stick around for a bit, you will appreciate Neocore's support and work with the community, both here and in the Discord. I haven't seen a more responsive game studio. Not all feedback is 100% taken on board, obviously, but a lot of what we report is (and close to 100% of bug reports), including the tweaking and fine-tuning of mechanics and gameplay.

2 years 51 days ago
Marcopolocs

Cheers, I posted very similar to what I said below, nothing too untoward, and then the post disappeared, so I assumed a mod deleted it. Never mind, and thanks for the compo mate ;).

----

Not to seem ungrateful, but I haven't seen anything on my season character - please PM me as to what you refunded. 300K credits + 5 fate is fine, I didn't expect anything anyway, had my whinge ;).

This comment was edited 2 years 50 days ago by Nostromo21
2 years 51 days ago
+1
Nostromo21
Why would we delete your report? I'm not sure what you imply here. Only those posts get deleted which are duplicate or the tone is unacceptable and lacks any constructive manner.


Regarding the problem: we are planning to release a hotfix later this month to remove a few issues and this one will be also included. Sorry for the inconvenience. 

Moreover, I compensated your loss a few days ago (in case you missed out on this).

2 years 52 days ago
Same thing happened to me with a relic construct weapon. I wasted 300K, 5 fate + mats to make a relic quality vivsector chainsaw, only to find out I couldn't equip it in any way & I had wasted over half my credits! I posted this earlier and the post appears to have been deleted. I'm only level 24, so yes, that's quite a lot to me.


Great work Neocore - I see you can find time to censor paying customers, but not fix a simple bug by removing redundant items from the vendor loot tables. And that was after I ditched my totally unplayable Psyker (what a mess this season with those horrible, obnoxious, constant warp anomalies!), so I restarted as tech adept and then found this gem of a bug the hard way. Looks like it's still not fixed after 3 months...


Fully expect this post to be deleted as well. If so, I will happily escalate all over other forums how you treat legit reports of bugs. :)

2 years 133 days ago
+1
That indeed looks like a bug. Previous weapon modules have been removed with the Void Brethren overhaul. Old blueprints occasionally appear here and there, but that is a bug. Weapons now level up through the tech fragment system and they no longer use weapon-specific modules.